Need some Help with a nilfisk advance ba 5321 floor scubber - Cleaning Talk - Professional Cleaning and Restoration Forum
 
Thread Tools Display Modes
post #1 of Old 11-03-2011, 01:59 AM Thread Starter
Junior Member
 
Join Date: Nov 2011
Posts: 3
Need some Help with a nilfisk advance ba 5321 floor scubber

Hi Guys,
This question is a bit of a long shot, but I have a nilfisk advance BA 5321 Floor Scrubber. This has worked great over the years however now even after fully charging it their no power to both the Brush nor the Vacuum yet it is fully charged.
I have checked the battery and the fuses to no avail.
I have emailed Nifisk but they want to send out a rep to look at it, I am positive its something simple. Now It has happened before and to my knowledge and we had someone come out at look at it before, and as far as I know he pushed a reset button somewhere on the machine which got it going again, however I can`t seem to find it. I really don`t want to bring another guy out here for 30 seconds to push a switch if thats all it is.
I was hopping some one here might have some experience with these things and might be able to help before I have to get the rep in and pay the big bucks.
Any thoughts is greatly appreciated,
Thanks,
soundguy_99
soundguy_99 is offline  
Sponsored Links
Advertisement
 
post #2 of Old 11-04-2011, 08:32 AM
J4K
Senior Member
 
J4K's Avatar
 
Join Date: Nov 2006
Location: Nebraska
Posts: 276
There are buttons on the bottom back of the unit, above the squeegee area, I think two of them if I remember correctly.
J4K is offline  
post #3 of Old 11-17-2011, 09:48 PM Thread Starter
Junior Member
 
Join Date: Nov 2011
Posts: 3
Sorry for the long time in replying back to you,
we Since looked over the entire machine and still can`t find this damn Reset,
We even tried calling someone, who didn`t know anything about this reset button, and said to check the voltage across the solenoid which there is. Outside of that we don`t know what is causing the problem. If we can`t find the reset button we can speculate its the circuit board which we were advised to buy a bran new machine instead.
I will say that after looking through a few manuals this specific machine doesn`t have a key switch on it nor does it have a power train, meaning you have to push it, which allot of manuals don`t indicate.
Again if anyone can help me out, or point me in the right direction, or anything I would really appreciate it,
This is a theater and were getting into our busy season, and were having to use a wet towel for the entire stage for now, until can either get this one working or get a new one, which probably won`t be for a bit.
So I would really appreciate any help,
thanks,
soundguy
soundguy_99 is offline  
Sponsored Links
Advertisement
 
post #4 of Old 11-17-2011, 09:54 PM
J4K
Senior Member
 
J4K's Avatar
 
Join Date: Nov 2006
Location: Nebraska
Posts: 276
This must be a different model than the one I have. If I have time this weekend I will take a picture of mine and post it here so you can see if it is the same.
J4K is offline  
post #5 of Old 11-17-2011, 11:55 PM Thread Starter
Junior Member
 
Join Date: Nov 2011
Posts: 3
Huge Thanks if you can do that,
Its driving us nuts, we would hate to have to get a new machine only to find out it was a simple reset to get it back working..LOl
So if we can rule that out then we can least get through our busy time, and either get a new one later or postpone it all together.
So I do appreciate it,
Thanks,
soundguy
soundguy_99 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Cleaning Talk - Professional Cleaning and Restoration Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in













Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome